I've checked it in, with:
> Perhaps "col_prepend_fstr()" would be a better name, along the lines of
> "col_append_fstr()"? The string could be "inserted" anywhere in the
> column, so "col_insert_fstr()" doesn't imply "at the beginning" to me.
that change, and:
> ...but libpcap 0.7 beta reserves 117, not 17, for it (in order to avoid
> the collision in question).
>
> It'd be a Good Idea if OpenBSD used 117 rather than 17 as well.
a change to support 117 for that encapsulation (and not to support 17 if
DLT_LANE8023 is defined as 17, so Ethereal built on systems that so
define it won't treat those captures as PFLOG captures), and:
> You should probably just unconditionally fake the header. Capture file
> format shouldn't depend on, or be defined solely by, header files on a
> particular OS.
changes not to use the OpenBSD include files to define the link-layer
header (and not to use the OS's header files to define PF_INET6, as
different systems define it differently), but to, on *all* platforms
(regardless of whether they have the OpenBSD include files in question),
to define it ourselves (and to define BSD_PF_INET and BSD_PF_INET6
values).
I also added an entry for "packet-pflog.h" to "Makefile.am", so that it
gets bundled with the release tarballs, and added an entry for
"packet-pflog.c" to "Makefile.nmake", so it gets built on Windows.