Hello,
I want to add support for add_seq_check and process_reassembled_data to wslua.
But I'm wondering how to put that into a class nicely. GHashTable
*fragment_table and GHashTable *reassembled_table are giving me some headache.
My current idea is to hide them in a Fragment class, but this class need to be
created explicitely. I could not find a similar example how to do that. Each
other constructor needs some parameters. How can a (transparent) constructor
be implemented?
Another point is how to handle the return value of fragment_add_seq_check
fragment_data*. I think it also usefull to put them into the fragment class.
It seems to me a bool return value have to be passed. Is this acceptable? I
didn't found another example in wslua.
As you might see, I'm rather new to C<->LUA interface and wuold appreciate any
recommendations how to add those features
Regards,
Alexander