Wireshark-bugs: [Wireshark-bugs] [Bug 8581] More intuitive and less ambiguous variable names and

Date: Mon, 15 Apr 2013 00:56:34 +0000

Comment # 9 on bug 8581 from
(In reply to comment #8)
> Patch applied with some fuzzing (due to r48849 which I committed just before
> I saw this one), but it doesn't quite compile with my GCC:
> packet-nfs.c:4097:2: error: 'attributes_follow' may be used uninitialized in
> this function [-Werror=maybe-uninitialized]
packet-nfs.c:8784:2: error:
> implicit declaration of function 'dissect_nfs_nfsstat4'
> [-Werror=implicit-function-declaration]

At this point it might be worth
> rolling the naming changes in at the same time since an updated patch is
> needed anyways?

- I don't see how 'attributes_follow' could possibly be uninitialized given the 
  following code:
      attributes_follow = tvb_get_ntohl(tvb, offset+0);
      proto_tree_add_text(post_op_attr_tree, tvb, offset, 4,
      "attributes_follow: %s (%u)",
      val_to_str_const(attributes_follow, value_follows, "Unknown"),
          attributes_follow);

- 'dissect_nfs_nfsstat4' doesn't exist in my version of the code. The patch
  changes 'dissect_nfs_nfsstat4' to 'dissect_nfs_status4'. How could this be?

- The "<field_name> duplicates PROTOABBREV of nfs" errors are true in the case
  of nfs.nfsstat3, nfs.nfsstat4, and hf_nfs_nfsstat all of which set 
  PROTOABBREV to "Reply status" but there is nothing wrong with that. 
  Shouldn't we just ignore those warnings (or remove that check from the 
  script?) =)   

- OK. I'll submit an updated patch that changes *_nfs_*4 to *_nfs4_*


You are receiving this mail because:
  • You are watching all bug changes.