Ethereal-dev: Re: [Ethereal-dev] Adding list-type data to a column

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: "Olivier Biot" <ethereal@xxxxxxxxxx>
Date: Fri, 6 Feb 2004 00:32:47 +0100
Should the check for the start of the column data be:
  if (cinfo->col_data[0]) {
    col_append_str(cinfo, el, separator ? separator : ", ");
  }
or should I use cinfo->col_buf[0] in the conditional addition of the
separator?

----- Original Message ----- 
From: "Olivier Biot"


| From: Guy Harris
| |
| | On Feb 5, 2004, at 1:19 AM, Biot Olivier wrote:
| |
| | > |I.e., call them "col_append_str()" and "col_append_fstr()", but
| add a
| | > |separator string argument.
| | >
| | > I think your proposal is OK, but we will have to update the 839
| | > occurrences of the col_append_X() methods :)
| |
| | Then that might not be the best idea.
| |
| | I can't think of much better names for your routines, unless a
name
| | with "sep" or "separator" were used.
|
| Maybe col_append_sep_str() and col_append_sep_fstr()?