Ethereal-dev: Re: [Ethereal-dev] Updates to NCP dissector.

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: "Greg Morris" <GMORRIS@xxxxxxxxxx>
Date: Wed, 25 Sep 2002 13:47:26 -0600
Joerg,
 
The reason for the boolean -vs- gboolean was due to a CVS update that I performed that could not resolve some conflicts. Marked up the code as <<<< version xxxx... So I had done my best at cleaning these up but missed one. I have cleaned this up as well as the unused variables.
 
Attached is a new diff for packet-ncp2222.inc. Unfortunately I cannot validate that you will not get anymore warnings since I do not see them under Microsoft Visual C++. I have adjusted the warning levels but I still do not get the detail that you report. If you run into anymore then you can forward the information to me and I will do my best (blindly) or you can attempt to resolve them yourself.
 
Thanks,
Greg


>>> Joerg Mayer <jmayer@xxxxxxxxx> 09/24/02 06:37PM >>>
On Tue, Sep 24, 2002 at 09:35:24AM -0600, Greg Morris wrote:
> This update add NCP 87/66
> Also add additional error codes, added hf_definition for super class
> (NDS). Cleaned up some unused variables (Warnings when building
> Ethereal). Fixed NCP type 0x9999 (server busy packets to echo
> information to summary information), Added subtree format to NDS
> dissector to cleanup display.

I've applied your patch except for the two things.

You replaced a variable of type gboolean by a variable of type boolean.
<         gboolean                resolve_eid=FALSE;
---
>         boolean                 resolve_eid=FALSE;
This leads to a compiler error on Linux with GCC (complete result of
compiler run included below). Was there a specific reason to make this
replacement?
The other one is the one below:
<                 strcpy(dest_buf, "String too long to process");
---
>                 strcpy(dest_buf, "String to long to process");

Ciao
       J�rg

PS: I don't know whether your diff command supports -c or even
  better -u. If it does, please create patches with -u, it makes
  them a) more readable and b) easier to apply in case anything
  has changed between the version you diffed against and the
  current version.
PPS: Here's the compiler output. Many of these warnings were
  caused by your previous ncp2222 patch, Gilbert had to fix
  a few in order to make it compile at all. Please have a
  look at them or tell me to do so and I'll see what I can
  do :-)

Including the gboolean -> boolean part:
packet-ncp2222.inc: In function `ncp_eid_hash_insert':
packet-ncp2222.inc:735: warning: unused parameter `conversation'
packet-ncp2222.inc:736: warning: unused parameter `ncp_rec'
packet-ncp2222.inc: In function `ncp_eid_hash_lookup':
packet-ncp2222.inc:769: warning: unused parameter `conversation'
packet-ncp2222.inc: In function `process_bitfield':
packet-ncp2222.inc:1424: warning: implicit declaration of function `strcat'
packet-ncp2222.inc: In function `print_nds_values':
packet-ncp2222.inc:1644: warning: comparison between signed and unsigned
packet-ncp2222.inc:1891: warning: too many arguments for format
packet-ncp2222.inc:1908: warning: too many arguments for format
packet-ncp2222.inc:1929: warning: too many arguments for format
packet-ncp2222.inc: In function `process_multivalues':
packet-ncp2222.inc:2405: warning: unused variable `value8'
packet-ncp2222.inc:2396: warning: unused variable `n'
packet-ncp2222.inc: In function `dissect_ncp_reply':
packet-ncp2222.inc:5311: warning: comparison between pointer and integer
packet-ncp2222.inc:4205: warning: unused variable `nds_error_offset'
packet-ncp2222.inc:4197: warning: unused variable `n_string'
packet-ncp2222.inc:4191: warning: unused variable `ncp_eid_rec'
packet-ncp2222.inc:4187: warning: unused variable `eid_conversation'
packet-ncp2222.inc: In function `dissect_nds_request':
packet-ncp2222.inc:5636: `boolean' undeclared (first use in this function)
packet-ncp2222.inc:5636: (Each undeclared identifier is reported only once
packet-ncp2222.inc:5636: for each function it appears in.)
packet-ncp2222.inc:5636: parse error before `resolve_eid'
packet-ncp2222.inc:5873: `resolve_eid' undeclared (first use in this function)
packet-ncp2222.inc:5631: warning: unused variable `nlength'
packet-ncp2222.inc:5628: warning: unused variable `nds_string'
packet-ncp2222.inc:5627: warning: unused variable `value2'
packet-ncp2222.inc:5626: warning: unused variable `value1'
packet-ncp2222.inc:5611: warning: unused variable `eid_conversation'
packet-ncp2222.inc:5609: warning: unused variable `nds_rec'
packet-ncp2222.inc: In function `dissect_ping_req':
packet-ncp2222.inc:8238: warning: unused variable `ett_nds_flags'

Without the gboolean -> boolean part:
packet-ncp2222.inc: In function `ncp_eid_hash_insert':
packet-ncp2222.inc:735: warning: unused parameter `conversation'
packet-ncp2222.inc:736: warning: unused parameter `ncp_rec'
packet-ncp2222.inc: In function `ncp_eid_hash_lookup':
packet-ncp2222.inc:769: warning: unused parameter `conversation'
packet-ncp2222.inc: In function `process_bitfield':
packet-ncp2222.inc:1424: warning: implicit declaration of function `strcat'
packet-ncp2222.inc: In function `print_nds_values':
packet-ncp2222.inc:1644: warning: comparison between signed and unsigned
packet-ncp2222.inc:1891: warning: too many arguments for format
packet-ncp2222.inc:1908: warning: too many arguments for format
packet-ncp2222.inc:1929: warning: too many arguments for format
packet-ncp2222.inc: In function `process_multivalues':
packet-ncp2222.inc:2405: warning: unused variable `value8'
packet-ncp2222.inc:2396: warning: unused variable `n'
packet-ncp2222.inc: In function `dissect_ncp_reply':
packet-ncp2222.inc:5311: warning: comparison between pointer and integer
packet-ncp2222.inc:4205: warning: unused variable `nds_error_offset'
packet-ncp2222.inc:4197: warning: unused variable `n_string'
packet-ncp2222.inc:4191: warning: unused variable `ncp_eid_rec'
packet-ncp2222.inc:4187: warning: unused variable `eid_conversation'
packet-ncp2222.inc: In function `dissect_nds_request':
packet-ncp2222.inc:5631: warning: unused variable `nlength'
packet-ncp2222.inc:5628: warning: unused variable `nds_string'
packet-ncp2222.inc:5627: warning: unused variable `value2'
packet-ncp2222.inc:5626: warning: unused variable `value1'
packet-ncp2222.inc:5611: warning: unused variable `eid_conversation'
packet-ncp2222.inc:5609: warning: unused variable `nds_rec'
packet-ncp2222.inc: In function `dissect_ping_req':
packet-ncp2222.inc:8238: warning: unused variable `ett_nds_flags'


--
Joerg Mayer                                          <jmayer@xxxxxxxxx>
I found out that "pro" means "instead of" (as in proconsul). Now I know
what proactive means.

Attachment: packet-ncp2222.inc.diff
Description: Binary data