On 11/21/2013 8:05 PM, Guy Harris wrote:
On Nov 21, 2013, at 4:37 PM, Michael Lum
<michael.lum@xxxxxxxxxxxxxxxxx> wrote:
Can someone tell me why code like this:
i++;
would have been changed to this:
i += 1;
?
If the code in question is stepping through a packet, and "i" is
actually "offset" or some such variable holding the offset into the
packet, and other code is doing "offset += 2" or "offset += 4",
people might have used "offset += 1" to make the style more
consistent and to put the field length into all the incrementing
lines of code.
You may be referring to one or more changes I made. :)
As Guy suggested, for consistency I tend to change 'offset++' to 'offset
+= 1'.
It does appear that I changed 'i++;' to 'i += 1;' in a few instances.
I must have been a bit over enthusiastic in those cases since there's no
real reason for that change.
Bill