On 6/26/2012 12:56 AM, Richard Sharpe wrote:
Hi folks,
I noticed some inconsistencies in the command naming. The following
patch fixes those (so that they now match between SMB and SMB2):
Index: epan/dissectors/packet-smb2.c
===================================================================
--- epan/dissectors/packet-smb2.c (revision 43186)
+++ epan/dissectors/packet-smb2.c (working copy)
@@ -5531,11 +5531,11 @@
/* names here are just until we find better names for these functions */
static const value_string smb2_cmd_vals[] = {
- { 0x00, "NegotiateProtocol" },
- { 0x01, "SessionSetup" },
- { 0x02, "SessionLogoff" },
- { 0x03, "TreeConnect" },
- { 0x04, "TreeDisconnect" },
+ { 0x00, "Negotiate Protocol" },
+ { 0x01, "Session Setup" },
+ { 0x02, "Session Logoff" },
+ { 0x03, "Tree Connect" },
+ { 0x04, "Tree Disconnect" },
{ 0x05, "Create" },
{ 0x06, "Close" },
{ 0x07, "Flush" },
Committed in SVN 43495...
Should the following also be changed ?
{ 0x10, "GetInfo" },
{ 0x11, "SetInfo" },