I've checked into the trunk a change to rename:
dissector_add() -> dissector_add_uint()
dissector_change() -> dissector_change_uint()
dissector_delete() -> dissector_delete_uint()
dissector_get_port_handle() -> dissector_get_uint_handle()
dissector_reset() -> dissector_reset_uint()
dissector_try_port() -> dissector_try_uint()
dissector_try_port_new() -> dissector_try_uint_new()
next_tvb_add_port() -> next_tvb_add_uint() (and a matching change of NTVB_PORT -> NTVB_UINT)
with #defines left behind so old code continues to build and work. The intent is to make it a little more obvious that this is for arbitrary unsigned-integer selectors, not just TCP/UDP/etc. ports (selecting on, for example, an Ethernet type actually works better than selecting on a port number...), and to make the names match what's used for string-based dissector tables.