http://anonsvn.wireshark.org/viewvc/viewvc.cgi?view=rev&revision=51353
User: guy
Date: 2013/08/14 12:39 AM
Log:
Copy over revisions from trunk:
------------------------------------------------------------------------
r50382 | guy | 2013-07-04 11:11:59 -0700 (Thu, 04 Jul 2013) | 2 lines
More details in a comment.
------------------------------------------------------------------------
r50379 | guy | 2013-07-03 17:39:54 -0700 (Wed, 03 Jul 2013) | 2 lines
Add more comments indicating what this is doing.
------------------------------------------------------------------------
r50334 | guy | 2013-07-02 18:43:39 -0700 (Tue, 02 Jul 2013) | 12 lines
WS_DLL_PUBLIC is now always WS_DLL_PUBLIC_NOEXTERN with "extern" added;
just define WS_DLL_PUBLIC_NOEXTERN inside the ifdefs, and define
WS_DLL_PUBLIC as WS_DLL_PUBLIC_NOEXTERN followed by "extern".
Then rename WS_DLL_PUBLIC_NOEXTERN to WS_DLL_PUBLIC_DEF, to clarify that
it's what should be used for definitions; at least on Windows, you
*have* to use it when declaring arrays without a size, and, whilst you
might be able to use WS_DLL_PUBLIC for definitions of functions and
perhaps data definitions other than no-size arrays, it might be clearer
to rename WS_DLL_PUBLIC to WS_DLL_PUBLIC_DECL and use it only for
declarations.
------------------------------------------------------------------------
r50332 | guy | 2013-07-02 17:38:41 -0700 (Tue, 02 Jul 2013) | 14 lines
OK, try having WS_DLL_PUBLIC always say "extern". If *that* doesn't
work, because it can't be used with definitions, we'll probably have to
have separate macros for declarations and definitions, as I don't think
MSVC likes
int foo[];
in a header file but should be fine with
extern int foo[];
Add some more comments while we're at it; you are in a twisty little
maze of #ifdefs, all different.
------------------------------------------------------------------------
r50329 | guy | 2013-07-02 15:08:23 -0700 (Tue, 02 Jul 2013) | 7 lines
Methinks the "not GCC 4 or later" #defines for WS_DLL_PUBLIC and
WS_DLL_LOCAL were reversed; that might be what's causing a build error
with ui/qt/main_status_bar.cpp.
Add some comments for #else's while we're at it, so it's easier to
figure out when particular sets of #defines are used.
and then back out the "rename WS_DLL_PUBLIC_NOEXTERN to
WS_DLL_PUBLIC_DEF" change, to minimize the number of changes.
Directory: /trunk-1.10/
Changes Path Action
+74 -11 ws_symbol_export.h Modified