File name changed(file.c->file_access.c), added a few words on data_offset.
_________________________________________________________________
High-speed Internet access as low as $29.95/month (depending on the local
service providers in your area). Click here. https://broadband.msn.com
--- /wiretap/README.developer 2003-04-02 14:21:45.000000000 -0600
+++ README.developer 2003-09-24 09:24:29.887000000 -0500
@@ -26,19 +26,31 @@
structure to point to that routine, otherwise set it to
"wtap_def_seek_read";
+ Wiretap applications typically first perform sequential reads through the
+ the capture file and may later do "seek and read" for individual frames.
+ The "read" routine should set the variable data_offset to the
+ byte-offset within the capture file from which the "seek and read" routine
+ will read. If the capture records consist of
+ capture record header
+ pseudo-header (e.g., for ATM)
+ frame data
+ then data_offset should point to the pseudo-header. The first
+ sequential read pass will process and store the capture record header
+ data, but it will not store the pseudo-header.
+
write a "close" routine, if necessary (if, for example, the
"open" routine allocates any memory), and set the
"subtype_close" member of the "wtap" structure to point to it,
otherwise leave it set to NULL;
add a pointer to the "open" routine to the "open_routines[]"
- table in "file.c" - if it uses a magic number, put it in the
+ table in "file_access.c" - if it uses a magic number, put it in the
first section of that list, and, if it uses a heuristic, put it
in the second section, preferably putting the heuristic routines
for binary files before the heuristic routines for text files;
add an entry for that file type in the "dump_open_table[]" in
- "file.c", giving a descriptive name, a short name that's
+ "file_access.c", giving a descriptive name, a short name that's
convenient to type on a command line (no blanks or capital
letters, please), and pointers to the "can_write_encap" and
"dump_open" routines if writing that file is supported (see
=