I'm in the process of cleaning of rolling my changes into
the CVS tree, got a little behind and have to do some manual
updates. I hope to get this done today or tomorrow. I plan
to create a diff file to post to the mailing list because the
changes are so large that I don't feel safe updating the CVS
tree.
As for Guy's comments -
> > 1) Modified the tvbuff struct to add the ds_name -
> >
> > #define DS_NAME_LEN 64
> >
> > gchar ds_name[ DS_NAME_LEN];
>
> Why an array rather than a pointer to an arbitrary-length string, so
> that:
>
> > 2) The tvb_new_real_data function is changed to add a ds_name field
> >
> > tvbuff_t*
> > tvb_new_real_data( const guint8* data, guint length,
> > gint reported_length, const gchar* ds_name);
>
> it'd do
>
> tvb->ds_name = g_strdup(ds_name);
Agreed. In addition I plan to set the ds_name pointer in
tvb_new_subset, not copy the string.
> > 7) Change dissect_packet to create the tvbuff with the name "raw".
>
> I'm assuming the name would be what shows up on the tab; would "Frame"
> be a better name, to indicate that the initial data source is the data
> in the current frame?
Yes, the name does show up on the tab.
Agreed. I didn't like the name 'raw' either.
Jeff Foster
jfoste@xxxxxxxxxxxx