Ethereal-dev: Re: [ethereal-dev] Popup packet window

Note: This archive is from the project's previous web site, ethereal.com. This list is no longer active.

From: Guy Harris <gharris@xxxxxxxxxxxx>
Date: Wed, 16 Feb 2000 21:24:25 -0800
> OK. Here are the files; a diff file fore gtk/menu.c and a new file
> gtk/new-win.c.  Of course you will have to add new-win.c into the make
> files.

1) "New Window", as a menu item, doesn't give much of an indication of
   what it does - it should probably indicate that the new window is for
   the currently-selected packet.

2) It should make only one call to "gtk_paned_gutter_size()" - there are
   only two panes, so there should be only one slider.  (Delete the call
   that does

  gtk_paned_gutter_size(GTK_PANED(u_pane), (GTK_PANED(u_pane))->handle_size);

   .)

3) There should be a list of all the tree-view widgets, and
   "set_ptree_line_style()" and "set_ptree_expander_style()" in
   "gtk/main.c" should set the style not only for the main tree-view
   widget but for all the widgets for the popped-up windows.

   (In addition, those routines should probably be called only when the
   GUI preference in question is being set; when creating a new
   tree-view widget, "gtk_ctree_set_line_style()" and
   "gtk_ctree_set_expander_style()" should be called directly, as
   there's no need to set the style on all windows when a window is
   being created, only the style on the window being created needs to be
   set.)